sublime使用

小nu用的编辑器大部分都是sublime, sublime升级之后增加了许多新功能, 但是坑也多, 下面是小nu碰到过的坑

1.安装好sublime, 打开文件进行编辑保存, 发现保存不了, 报错大概是一样的错误, 下面是小nu的解决方法

{
"atomic_save": false,
"auto_complete": true,
"color_scheme": "Packages/Color Scheme - Default/Monokai.tmTheme",
"font_size": 11,
"ignored_packages":
[
"Vintage"
],
"theme": "Soda Dark 3.sublime-theme",
"update_check": true,
"word_wrap": true
}

 

按照上述方法就能解决无法保存的问题了

2.sublime安装之后没有package control包, 推荐安装步骤地址:https://jingyan.baidu.com/article/c14654134b8bde0bfcfc4c9a.html

第一种方法得配合版本使用, 推荐使用第二种方法

3.package control包不能安装插件, 总出现弹窗:

package control: There are no packages available for installation问题,

小nu已踩过坑, 说修改ipv6地址以及修改package control配置都不怎么管用, 下面是小no亲测解决方法

方法: 下载package control sublime-package, 下载地址:https://link.zhihu.com/?target=https%3A//packagecontrol.io/Package%2520Control.sublime-package

打开sublime3->首选项->浏览插件(程序自动打开插件目录)

删除package control 目录, 把刚下载得插件package control sublime-package 复制到packages目录

关闭sublime3, 重新打开

按住ctrl+shift+p, 输入package control找到package control:install package, 按下确认键, 就会发现不会报错并且可以安装插件了

 

您可以选择一种方式赞助本站

发表评论

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: